Keyboard Shortcuts

Here is a list of keyboard shortcuts to perform various functions of Statistics101:

Shortcut

Description

Action

Ctrl+A

Select All

Selects entire contents of the active window—either the Edit Window, the Debug Window, or the Output Window.

Ctrl+B

Toggle Breakpoint

Sets or cancels a breakpoint at the line containing the cursor. This is only effective when you are in the Debug tab of the editor.

Alt+B

Clear All Breakpoints

Removes any breakpoints that are currently set.

Ctrl+C

Copy

Copy selected text to clipboard. The selected text may be in either the Edit window, the Debug Window, or the Output window.

Ctrl+D

Debug

Enter debug mode, continue execution in debug mode, or pause at current instruction, depending on the state of the debugger.

Ctrl+E

Edit Variables/ Commit Changes

(In Debug Variables window) Toggles between Edit Variables and Commit Changes state.

Ctrl+F

Find/Replace

Displays the Find/Replace dialog to search the text in the Edit window. Any text selected in the editor will appear in the "Find What:" text box.

Ctrl+G

Continue

Continue a running, but paused, program when program has been paused by the PAUSE command.

Ctrl+H

Backspace

Backspace delete in the Edit Window. Deletes the character to the left of the cursor.

Ctrl+I

Indent Program

Indent program text in the Program Panel. This shortcut corrects the indentation of commands that are enclosed in REPEAT, WHILE, or IF commands and their corresponding END commands. It does not change the indentation of any comment lines (i.e., lines beginning with the apostrophe.)

Ctrl+Shift+I

Indent Program to Upper Case

Indent program text in the Program Panel displaying the command names in Upper Case. This shortcut corrects the indentation of commands that are enclosed in REPEAT, WHILE, or IF commands and their corresponding END commands. It does not change the indentation of any comment lines (i.e., lines beginning with the apostrophe.)

Alt+I

Indent Program to Lower Case

Indent program text in the Program Panel displaying the command names in Lower Case. This shortcut corrects the indentation of commands that are enclosed in REPEAT, WHILE, or IF commands and their corresponding END commands. It does not change the indentation of any comment lines (i.e., lines beginning with the apostrophe.)

Ctrl+K

Check Program Syntax

Check syntax of entire program that is in the Edit window. Any errors found will be displayed in the Output Window. Does not run the program even if no errors are found.

Ctrl+L

Show/Hide Line Numbers

Toggle between showing and hiding line numbers in the Program Panel.

Ctrl+N

New File

Opens a new empty page in the Edit window. If the Edit window's contents had not been saved, you will be asked if you want to save those contents before the new empty page is displayed.

Ctrl+O

Open File

Displays a file-Open dialog allowing you to choose an existing program to load into the Edit window.

Ctrl+P

Print Program

Print the contents of the visible window in the Program Panel.

Ctrl+Shift+P

Print Output

Print the contents of the Output window.

Ctrl+R

Run Program

Runs the program that is in the Edit window.

Ctrl+S

Save File

Saves the program text that is in the Edit window.

Ctrl+T

Step

In debug mode, executes one command and waits at the next command.

Ctrl+U

Include Lib File(s)

Invokes an Open File dialog listing all the files in the subroutine library, lib. You can select one or more files, then click the Open button. Statistics101 will then add an INCLUDE command for each file you selected to the top of your program in the editor.

Ctrl+V

Paste

Paste the text contents of the clipboard into the Edit window. (You can't paste into the Debug Window or the Output window.)

Alt+V

Paste from Spreadsheet

Pastes the contents of the system clipboard into the Edit Window at the cursor. The clipboard contents are assumed to have been copied from a spreadsheet program such as Microsoft Excel by selecting the desired cells in the spreadsheet and choosing Copy (Ctrl-C). Each table row (or column) is converted to a LET command before it is pasted into the editor.

Ctrl+X

Cut

Cut the text selected in the Edit window into the clipboard. (You can cut text from the Output window using Ctrl+Shift+X.)

Ctrl+Shift+X

Clear Output Window

Clears the contents of the Output text window, or the selection in the Output text window without asking for confirmation.

Alt+Shift+X

Close Output Tabs

Closes all graph tabs that may be displayed in the output panel without asking for confirmation.

Ctrl+Y

Redo

Redo

Ctrl+Z

Undo

Undo one by one the last changes that you made to the Edit window. There is an unlimited number of undoes. Saving the contents of the Edit window resets the undo. Opening a new file also resets the undo.

Esc

Abort Program

Causes a running program to abort. You will be given a chance to cancel the abort request.

Ctrl-Space

Show Command/variable Options

If pressed when the cursor is anywhere in a partial or full command name, subroutine name, or variable name in the editor, this shortcut (the Ctrl key and the space bar) will display a popup menu that lists all the commands, subroutines, and/or variables that begin with the letters up to the cursor. You can then select the desired command/subroutine/variable from the list without having to type the whole word. If you make a selection, that selection will replace the word that the cursor is in.

While the popup menu is visible, you can use the mouse or the up and down arrows to change the menu selection. You may use the left and right arrows to move the cursor left and right within the word. Any characters you type will be inserted after the cursor and the menu will update to reflect the new characters as you type. The Delete and Backspace keys are valid and function as they normally do.

If you want to exit the menu without making a selection, you can do so by typing the Esc key. If the cursor is not in a word, or if the consecutive characters in a word up to the cursor do not match the start of any command or subroutine name, this shortcut will have no effect. The shortcut is disabled during Debug and in the Debug tab's window because editing is disabled during debugging.

F1

Help at Cursor

When you press the F1 function key, if the cursor is on a word that is the name of a command, then the help browser will display a window containing a complete description of that command.

If the cursor is on a word that is the name of a subroutine that is in the lib directory, then the subroutine browser will display the description and code for that subroutine.

If the cursor is on a word that is the name of a subroutine defined in the current program, then the editor will scroll to that program's definition and highlight it.

If none of the above is true, then the first word on the line (the command or subroutine name for that line) will be described in the help browser, the subroutine browser, or the editor as appropriate. Equivalent to the "Help at Cursor" editor popup menu item.

F2

Wizard for Command at Cursor

When you press the F2 function key, the Wizard for the command that is on the line containing the cursor will be displayed. If the first word on the line is not a recognizable command, the most-recently displayed wizard will be displayed.

F3

Command/

Subroutine Index

When you press the F3 function key, the Command/Subroutine Index will appear. This is equivalent to selecting the "Command/Subroutine Index" menu item of the Help menu. Clicking on any command in this list will open the help window for that command. Clicking on any subroutine in the list will open the Subroutine Browser displaying the subroutine.

F4

Show Debug Window

When you press the F4 function key, the Debug Window will appear. This is equivalent to selecting the "Show Debug Window" menu item of the Help menu.

F5

Show Subroutine Browser

When you press the F5 function key, the Subroutine Browser will appear. This is equivalent to selecting the "Show Subroutine Browser" menu item of the Help menu.

F6

Show/Hide Output Panel

This is a toggle. When you press the F6 function key, the Output Window will be hidden or revealed by moving the split-pane border either to the bottom of the edit window or to its last position. This is equivalent to selecting the "Show Output Panel" menu item of the Help menu.